Vulnerabilities
Vulnerable Software
Apache:  >> Activemq  >> 5.16.0  Security Vulnerabilities
XStream before version 1.4.14 is vulnerable to Remote Code Execution.The vulnerability may allow a remote attacker to run arbitrary shell commands only by manipulating the processed input stream. Only users who rely on blocklists are affected. Anyone using XStream's Security Framework allowlist is not affected. The linked advisory provides code workarounds for users who cannot upgrade. The issue is fixed in version 1.4.14.
CVSS Score
8.0
EPSS Score
0.827
Published
2020-11-16


Contact Us

Shodan ® - All rights reserved