Vulnerabilities
Vulnerable Software
Nodejs:  >> Undici  >> 5.10.0  Security Vulnerabilities
Undici is an HTTP/1.1 client for Node.js. Starting with version 2.0.0 and prior to version 5.19.1, the undici library does not protect `host` HTTP header from CRLF injection vulnerabilities. This issue is patched in Undici v5.19.1. As a workaround, sanitize the `headers.host` string before passing to undici.
CVSS Score
6.5
EPSS Score
0.011
Published
2023-02-16


Contact Us

Shodan ® - All rights reserved